ArchBlocks Products and AutoCAD Compatibility

I get questions every once in a while asking if the ArchBlocks.com products are compatible with certain versions of AutoCAD. All of the ArchBlocks.com products are saved back to the AutoCAD 2000 version, so they will work in all versions of AutoCAD back to AutoCAD 2000. This includes all the CAD blocks, fonts, hatch patterns, and title blocks.

If you have a very old version of AutoCAD, like AutoCAD R14, send me a note and I can send you the products for any older version.

Please feel free to send me any questions you might have.

Good Luck on all your projects!

~Kevin

Comments are closed.